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any way. Any other use, including the reproduction, modification, distribution, transmission, 
republication, display, or performance, of the content on this site is strictly prohibited. 

This section is intended to be a grab bag of tips and tracks for working with Inventor. 
Many of them have come from readers like you who have found a neat way to overcome 
a problem. Some are from Autodesk designers, some from me. Take the all with a grain 
of salt, as I have not verified them all.  Check back as the document will be updated from 
time to time.  All tips are applicable to R5 and up unless otherwise noted.

1.  "Error" Messages

This tip comes from Tom Sturtevant of Autodesk and concerns the "Active part does not 
match the table values" message.

I think the point of that "error" is generally misunderstood - in 
fact it's not an error, but an opportunity.  Inventor assumes 
that the factory will be in sync with the default row in the 
table.  It supports this in two ways:

1. When you edit the default row values in the table, the values 
in the default row are applied to the model.  (This is handled slightly differently 
for edits via Excel or via Inventor's iPart Author dialog.)
2. When you modify values in the part, you have the option to 
"update the table before continuing".

This enables a workflow in which you edit the table by editing 
the factory part.  Like this:
  * create a factory part
  * using iPart Author command add appropriate columns.  Add all 
the rows you want, but only modify the KEY values.  Exit iPart 
Author command.
  * in the browser, switch to a different default row.
  * edit the part so it correctly represents the current default 
row.
  * switch to another default row - it will ask "... Do you wish 
to update the table before continuing?" answer Yes!
* repeat for all rows

This is probably more trouble than it is worth for many 
factories, but at some level of complexity it is easier to set a 
row configuration through Inventor editing than through table 
edits.  For large tables you can do this for a few selected rows 
then use excel for the bulk replication.  If you are modifying 
color or material for each row, you don't have to worry about 
spelling errors.  Of course it's not quite a complete solution.  
I don't think it works for threads (yet).  It won't work 
for file names.  It should work for parameters, properties, 
feature suppressions, iMate values, and color and material 
styles.

Thanks to Tom for this tip! -Sean



2.  Multiple colors in iParts

Someone wrote me the other day asking about multiple colors in iParts. For example he 
had a fitting but wanted the end of the fitting to change color for English or metric. This 
is possible but it takes a bit of forethought. 
You need to make the features that will change color the default color. In other words 
don't change their color via the properties dialogue. 
Next go back to the parts that will remain a constant color and using the RMB on the 
features in the browser, select properties and change them to whatever color you want. 
The premise here is that the iPart author can only control the "base" color, not the one 
that can be set via properties. It's kind of backwards from the way you would normally 
draw parts (make the non-changing parts the base color) but it works. 

Click here to download the iPart shown below.  In this example we set the base color to 
Green and vary the color of the cylinder by the iPart table. Changing the diameter of the 
cylinder changes the cylinder's color. 

3.  Reduce Typing in Excel

Typing in information in Excel can be repetitive. If for example you have a column for 
Threads1:Designation and another for Length and you want to make the filename a 
combination of the thread size and length you can use the Excel "concatenate" function. 
This allows you to combine the information from multiple cells into one cell. See the 
Excel help for more information. 

4.  3D Text in Inventor

As of version 5.3 Invcentor does not have a built in capability to extrude or emborss text 
in a model.  There are two ways to achieve this effect.  One is to make your text in 
AutoCAD and use the Express tool “Explode Text” to obtain the text as lines.  You can 
then import this sketch into the model and extude or cut it.  A much more legant way is to 
use Charles Bliss’ 3D Text Macro.  You can find it at his site.  Read the installation 
instructions and have a blast with it.  It’s really a great addition to IV.

http://www.cbliss.com/inventor/iCode/index.htm
http://www.sdotson.com/tutparts/color.zip
http://www.sdotson.com/tutparts/colorpart.zip


4.  Strange Characters in iPart Children

A recent post in the NG reminded me that I did not address some aspects in my iParts 
tutorials (since updated).  If you notice that some of your iPart children have strange 
characters in the filename: e.g. HexBolt1(_FS)4-20.ipt or IPNA9(_BS)24.ipt then you 
have illegal characters in your filename column.  Illegal characters include: / \ * ? $ and a 
few others.  (I’m attempting to compile a complete list.  If you find others please email 
me).  While these characters ARE legal in the description, title, part number etc... fields 
they are not legal for filenames.

5.  Make detail prints of each iPart Variant

This is a much asked question and the best way we have found so far is to create an 
assembly and insert one of each of the iPart variants into the assembly.  Now make 
details from the iPart children that were created.  Not the most elegant solution but one 
that works.  Some of the VB gurus are working on a way to automate this process.  More 
news as it develops.

6.  Is My Video Card Supported / Which Driver Should I Use

Visit http://support.autodesk.com/inventor-graphic-cards/ for all your answers

7.  Adaptively is Grayed Out on the Part I Want to be Adaptive

This is likely due to having used the part as adaptive in another assembly.  An adaptive 
part cannot be used in two different assemblies.  If you no longer want it to be adaptive in 
the first assembly and want it to be adaptive in the second (current one) open the adaptive 
part and select Tools/Document Options/Modeling Tab.  Uncheck the “Adaptively used in 
assembly” checkbox.  Save the file ands you should now be able to make it adaptive in 
the second assembly.

8.  How do I prevent parts from showing in the BOM (Parts List)

This is useful when you have to create some existing feature or customer supplied parts 
to model around but you don’t want them to show up in the BOM.  In the assembly, 
RMB on the part and select the Properties/Occurrence tab.  Check the “Reference” 
checkbox.  No changes will be visible in the assembly.  When you place a view od the 
assembly in the IDW the parts will likely be “phantomed” out.  You can RMB on the 
view and select Edit View.  In this section you can control the display of reference parts 
(Normal, Phantom or Hidden).  Regardless of the display the parts will not be displayed 
in the BOM.

8.  Make Model Rotate Automatically

http://support.autodesk.com/inventor-graphic-cards/


More of a parlor trick than anything else but I’ve found it useful for presentation 
purposes.  Choose the orbit command (don’t hold down F4) then as you orbit the model 
hold down the SHIFT key.  Now simultaneously release the SHIFT key and the mouse 
button.  The model will continue to rotate at the speed and direction when you let go of 
the mouse button.

8.  Save Model as a Graphics File

You can export IV assemblies, parts and drawings as BMP files.  To do this select Save 
Copy As.. and use the file type pull down to select BMP.  Now before saving the file 
choose Options.  You will be presented with a dialogue box with a X and Y value.  Enter 
a value (say 1000) for X and Y (they need to be the same or Y needs to be left as 0).  
Now save the file.  Compare this to a file saved at 500 X 500.  This controls the size of 
the IV file.  The larger the number the larger the file size in MB and the better clarity that 
is generated.  Use caution with values above 4000 as the file size can grow to enormous 
levels.  You can now (and should) save this BMP as a JPG or GIF file to reduce the file 
size.

9.  What’s New Dialogue Getting Old Real Fast

IV 5.3 has a problem on some installation that causes the “What’s New” dialogue box to 
appear constantly.  The remedy for this is to go to Tools/Add-Ins and search for DSS 
Popup Monitor.  Uncheck both boxes.  The What’s New problem should now be OLD 
news.

10.  IV 5.3 and Volo View Install Problems

Before installing IV 5.3 be sure to uninstall Volo View Express from your machine.  The 
installation of 5.3 requires Volo View Express 2 and it will not successfully install over 
the older version.  Also be aware that there are two different versions of VVE on each 
CD of the AIS.  The one you want to install is the one of the AIS #1 CD (the one with IV, 
not MDT on it)

11. Get a Hold on Those Bolt Circles

This tip comes from Quinn Zander and address a simple way to construct bolt circles that 
are easily changeable based on horz. and vert. dims.

“Using a Pattern in a part for bolt patterns has many advantages. The
spacing can be easily controlled with parameters, and by using the
Associative Pattern tool in an assembly, fasteners can be placed
parametrically into the pattern semi-automatically.

Let's take our rectangular face that needs a 4-bolt pattern.

On the sketch we drop a hole-point someplace in the lower right corner
of the sketch.



Start the Line tool (we are not extruding anything so using a Normal
linetype is acceptable and saves 1 step over choosing Construction) and
sketch a horizontal line between the midpoint of the vertical sides of
the rectangular face, and sketch a vertical line midpoint between the
top and bottom edges making a "centered" pair of lines.

Now look up the bolt pattern measurements in the book you are
referencing and start dimensioning the Hole Point.

To dimension the hole point, select one of those lines that was just
drawn, and the point, RMB->Linear Diameter and plug the value. Do the
same for the other dimension. Hit "H" on the keyboard (directly from the
sketch) and drop the hole.

Go to Parameters and rename the 2 d values to bp_horiz and bp_vert
for bolt pattern horizontal and bolt pattern vertical.

Start the Rectangular Pattern tool, select the hole and defining edges
for direction, but when plugging the value for the spacing, click the
rollout arrow and select "List Parameters".
bp_horiz and bp_vert will show up in the box for selection.
No thinking, always centered, easily changed, no dividing up the
measurements from the book (even if they are specified in abnormal units
like cm).
Simple and fast.”

12.  Stop Picking on Me..

When in detailing (.idw) mode things can often get crowded which leads to picking items 
that you don’t want to pick.  That’s when filters come in handy!  In an .idw choose the 
select pulldown and choose Filters.  This will open a new dialogue that allows you to 

select what items are actually “selectable” in the .idw.  Tired of always picking the view 
box when you really wanted the detail circle?  Uncheck “views” from the list.  At the top 



of the box are some predefined filter setups and an option to add your own.  Just don’t 
forget to recheck the boxes or you’ll go nuts trying to get that view to move.

13.  I’m getting Dizzy

To turn on Inventor’s graphical statistics (aka the “spin test”) change the following 
registry setting.

HKEY_CURRENT_USER\Software\Autodesk\Inventor\RegistryVersion5.1\System\Pref
erences\Scene Manager\Debug\Post Statistics = 1

This will place a small display in the bottom of the screen that lists statistics about your 
model.

14. Hole Centers? We Don’t Need No Stinking Hole Centers

This tip comes from Kent Keller via the Inventor NG:

Holes can be placed on any point in the sketch (not just on hole centers).  You can select 
the end of a line or the coiencident point of two lines that are joined.  The hole feture 
command will not pick these points automatically but you can select them in the sketch.  
This can be useful for making bolt circles.  Create a polygon with the number of edges 
equal to the number of holes oyu want then select the corner points of the polygon as 
your hole centers.

15.  One the Surface it’s Just a Symbol

This tip comes from Doug Dupont via the Inventor NG:

“I remember reading back a week ago that someone did not like the way 
Surface Texture Symbols where inserted and having to enter text each 
time. I found a better way. Enter your first symbol and them RMB and 
copy it. Now RMB again and paste it as many times as you would like. 
When pasting it might go to the wrong side of the line or dimension. 
All you need to do it drag it over to the proper side. This is a time 
saving if you add a lot of surface symbols and don't like to type.”

16.  Dictation for Inventor

This tip comes from Lars Sandberg from the Inventor NG and concerns the use of the 
transcripting function in IV.  This used to be an obvious switch in the Tools>Application 
Options dialogue but in later versions of IV it was hidden.  Additional info on 
transcripting can be found at http://www.mymcad.com

“The key's below ensures that *.tf files are written to c:\temp
Transcription is some kind of real-time backup. If a crash occur you 
can see that in the bottom of the *.tf file (look for newest 
timestamp). Remove read-only attribute and edit that part 
Away.

http://www.mymcad.com/


[HKEY_CURRENT_USER\Software\Autodesk\Inventor\RegistryVersion5.2\System
\Preferences\Transcript]
"C:\\Temp\\" 
"TranscriptingOn"=dword:00000001
"TranscriptSkipErrors"=dword:00000001
"TranscriptStopOnError"=dword:00000000
"ShowCPUTimes"=dword:00000000
"AllowReplay"=dword:00000001

17. Squares and Cubes and Superscripts, Oh My!

This tip comes from Quinn Zander via the Inventor newsgroup and concerns how to get a 
superscript characters (2 for squared, 3 for cubed) in a text dialogue box.

In the text dialog, hold the ALT key down and type (with the other hand 
on the number-pad, not the top row of number keys) 0179 for cubed and 
0178 for squared; let go of the ALT button and finish typing.

You can insert other characters this way by going to Start/Programs/Accessories/System 
Tools/Character Map and selecting a character.  Look in the bottom right hand corner 
and note the keystroke combination.

18.  Possible Solution to the Imbedded Image Bug

From Bill Bogan et all at Autodesk….

Inserted image displays only an icon and filename
When you insert an image into a sketch, you may see only an icon with the filename 
below it. This can happen when the application associated with the file type does not a 
very good job as an OLE Server.

Microsoft Paint  displays .bmp, .jpg, .jpeg, and .gif formats. If you have trouble 
displaying one of these file types, try one of these solutions:

� Remove MSPaint from your system and reinstall it.
or

� Or change the registry setting for the file type. The following example uses the  
.bmp file type:

Problem:
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.bmp]
@="ImageComposer.bmp"

Change it to: 
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.bmp]
@="Paint.Picture"

 where @ is the ‘Default’ string name in regedit.



This sets Microsoft Paint as the default editor. To open an image with another editor, do 
the following:

1. Open Explorer
2. Select Tools>Folder Options>File Types Tab.
3. Find bmp in the list of file types.
4. Select Advanced.
5. Add a new action i.e. (“OpenBmp”) and set it to your desired application (i. e. 

"C:\Program Files\Common Files\Microsoft Shared\PhotoEd\PHOTOED.EXE" 
"%1")

6. Set Action as Default

19.  Making Threaded iParts a Bit Easier

David Zinn gave me a tip that cleans up your iPart tables on threaded iParts quite a bit.

If you create a custom property named ThreadX:Family (where X is 1,2,3 etc..) and give 
it a value of ANSI Unified Screw Threads (or ANSI Metric M Profile or NPT etc..) and a 
property named ThreadX:Class and set it’s value to 2A (or 1A or 3A, whatever is correct 
for this thread) you do not have to include these values in each row of your iPart table.  
All that is needed is the ThreadX:Designation.  Save a lot of clutter in the iPart table 
and/or Excel sheet.

Great tip David!

20.  Quickly Change Precision of Dimensions

Gary Cook via the NG gave us this quick tip.

“…double clicking on a number and pressing "3" will set the precision to 3 decimal 
places, "2" will set it to 2 places, etc. Pretty fast, a good tip.” 

I agree!

21.  Too Many Ways to Zoom in Inventor (R6 Only)

If you don’t like how Inventor R6 changed the way the model zooms you can edit this 
behavior in the registry.

HKEY_CURRENT_USER\Software\Autodesk\Inventor\RegistryVersion6.0\System\Pref
erences\Display:Viewing Command Options

Changing it to the #s below will change how Inventor zooms:



0 :old Inventor behavior (zoom to center of screen)
1: zoom to the cursor
2: reversed zoom (MDT-style) zoom to center of screen
3: reversed zoom (MDT-style) to the cursor

22.  Text Decals in Inventor (R6 Only)

This tips comes from Udaya Gunasena of Autodesk:

You could try using a Word text-box to create text decals. Keep the
text box on the top left corner, and adjust the page margins to be
inside the text box boundary. Use "Format Text Box" to set fill
color or to have no fill color (transparent).

23.  Creating Macros to Run Simple Commands (R6 Only)

Sometimes there is not a tool button for a command you want to easily access via a tool 
button.  You can simulate these commands using Send Keys.  Open your default.ivb 
macro template and enter the following information in Module1

Public Sub iProperties()
   SendKeys "%f", False
   SendKeys "t", True
End Sub

Send Keys are a way to send keystroke information to the application.  In our example 
the first line sends %v which is (Alt-F, which will open the File menu bar).  Then it sends 
a “t” which will select iProperties (note the underlined hotkeys for each menu item).  The 
True at the end of the last line signifies that we are done and the commands can execute.

See http://makeashorterlink.com/?D2FD62213 for more info on how to script keys 
such as Shift, Ctrl, and the function keys.

When you ruin this macro the iProperties menu will now be opened.  See below for how 
to assign this macro a custom icon.

24.  Custom Icons for Macros (R6 Only)

You can make icons for your macros to be used in toolbars.  First you will need to create 
a BMP image of the icon.  For small icons the size is 17 x 17.  For large icons it’s 33 x 33 
(I think).  If you only used small icons you do not have to make a large icon.  You can 
use transparency in the icons by defining the transparent color in the lower right pixel.

Once you have the icons save them to the same directory as the macro and name them.

http://makeashorterlink.com/?D2FD62213


ModuleName.SubName.Size.bmp

Where ModuleName is the name of the module in the macro, SubName is the subroutine 
name and size is either small or large.

And example would be”

Module1.ShowHide.Small.bmp   or Module1.iProperties.Small.bmp

Now go to Tools/Customize/Commands.  Select Macros.  In the right pane you should 
see all Macros that are currently loaded.  (Note: all macros in your default.ivb file are 
loaded by default, that’s why I suggest keeping your Send Keys macros in that module)

The macro should have the custom icon next to it.  If it shows an infinity symbol (a 
mobius strip looking object) then your BMP is either in the wrong location or is named 
incorrectly.  Now simply drag the icon onto a toolbar.

You should now have one click access to your macro.

Download http://www.sdotson.com/tutparts/sendkeys.zip for a list of macros and 
toolbar icons to have one click access to hiding and unhiding user and origin work feature 
geometry.

25.  Oh Where, Oh Where has my Print Icon gone? (R6 Only)

Somehow the print icon got left off the standard toolbar in R6.  While you can access 
printing commands via Flie>Plot it is nice to have a button. To add the icon to your 
toolbar go to Tools>Customize and click on the last tab. Highlight Management in the 
left hand pane and then drag the print icon onto the standard toolbar in Inventor. You 
must do this for each file type. e.g. start a new part file and do this, then close and repeat 
with assembly, presentation and detail drawing file types.

26.  Oh Where, Oh Where has my Print Icon gone? (R6 Only)

Somehow the print icon got left off the standard toolbar in R6.  While you can access 
printing commands via Flie>Plot it is nice to have a button. To add the icon to your 
toolbar go to Tools>Customize and click on the last tab. Highlight Management in the 
left hand pane and then drag the print icon onto the standard toolbar in Inventor. You 
must do this for each file type. e.g. start a new part file and do this, then close and repeat 
with assembly, presentation and detail drawing file types.

27.  Decals Appear as Icons? (R6 Only)

You likely have .bmp file types associated with a viewer other than MS Paint. To fix this, 
see tip # 18 above.

http://www.sdotson.com/tutparts/sendkeys.zip


28.  I’m Seeing Red! (R6 Only)

Why do some of my project paths appear in red? There are nested paths. 

For example if you have a workspace defined as:

C:\project

and a local or workgroup search path defined as 

C:\project\parts 

the latter path will appear in red.

See the Autodesk Inventor File Management Document.doc on the 1st AIS CD for more
info about projects and how they work.

29.  Replace Component Trick

Often you want to make a change to a component but want to keep the original part.  If 
the part is constrained in an assembly it can be a real pain to delete it and replace it with a 
copy.  One trick to retain your constraints is to open the part, Save Copy As to a new 
name.  Now open the assembly (or just switch back to it) and select the old part and issue 
the replace component command and select the copy of the part.  All of the constraints 
should be respected.  The key is that the copied part is NOT opened before you replace it.

30.  Make detail prints of each iPart Variant REVISITED

Tip #5 (Make detail prints of each iPart Variant) was written back in R4 so a lot has 
changed since then.  While there is still no good way to make a IDW of each iPart child, 
Autodesk provides a sample VB routine that can be used to generate all of the children of 
an iPart (that ½ way there).  Look in

…\Autodesk\Inventor 6\SDK\Samples\VB\iPart 

to find this routine.

31.  Tap Tap Tap: New Pipe Taps Sheets in Threads.xls (R6 Only)

Many users have found that if you copy the NPT tab of threads.xls and change it to be, 
for example a BSP thread type, it works in the model just fine, but when you use the hole 
note command in an IDW it still lists NPT.  To change this open the newly created sheet 
and find the hidden column BB.  Unhide it and you will see the hidden NPT designation.

Thanks to Michael Puschner via the newsgroup for this tip.



32.  Multi-Lingual iParts

If you find that Inventor users who use a different language version cannot read parts of 
your iParts this trick should help.  Instead of using the terms Computer and Suppress you 
can simply use a 1 or a 0.

Thanks to Tom Sturtevant of Autodesk for this tip.

33.  Creating IDWs of a Series of Similar Parts

Submitted by Udaya Gunasena of Autodesk

1. Convert your original part in to an iPart factory (Tools > Create iPart). 
2. In the "Other" tab add an item called "Configuration". Make it a key (key #1) 
3. Set its value to be "A" in the first row. 
4. Add another item called "dummy", and make it a custom parameter column. This is 

so as to be able to name iPart member instances, as well as to be able to add extra 
features to iPart member instances. 

5. Select any other parameters or features that you might want to change. It's not 
essential that you figure out every thing up front, we can add or delete later. 

6. Add the necessary rows (with configuration values "B", "C", etc.), one per each 
variant. Again, remember that we can edit this later. 

7. Save this part. 
8. Create a dummy assembly and place the iPart factory selecting "A". Let's name this 

part A.ipt. Close the assembly without saving. 
9. Make drawing of A.ipt (called A.idw). 
10. Use Design Assistant to copy A.idw and A.ipt as B.idw and B.ipt. Note that B.ipt 

should depend on the original part (which is the iPart factory). 
11. Open B.ipt and expand the browser item called Table. Select the row "Configuration 

= B". B.ipt should change to reflect the new configuration. 
12. Repeat steps 10 and 11 for each variant. 
13. If you realize that you need to create a new variant that needs a new parameter just 

modify the iPart table and add that parameter.

34.  Custom Model Properties in IDWs

Many people have asked how to get custom properties in a model into an IDW titleblock 
or sketched symbol.  This process explains it.

1. Create a *properties* template part, or use your current part and/or assembly file 
templates.  Add any and all custom properties to this template with blank values. 

2. Edit a drawing template that you will use when creating drawings that require copied 
custom properties. 

3. Select Tools > Document Settings and go to the second tab.
4. Set the source file to the model template in the lower portion of this dialogue. 



5. Check Copy Model Properties, and then click the Properties button. 
6. In the Properties dialog box, select the custom properties to copy. Click OK then OK.
7. Edit the desired title block definition in the drawing template to add the model 

properties. At this time you can also create or edit  sketched symbols with the desired 
model properties.

8. In the property field command, the type list now includes a Custom Properties -
Model item. 

9. Select from the list of custom model properties you imported. 
10. Save the title block definition and the template. 
11. To use, start a new drawing based on the template, and place a drawing view from sa 

model that was based on the template you modified in step 1.  The values will be 
automatically displayed in the property field placeholders in the TB. 

12. Any changes to the custom properties in the model will be tracked in the drawing title 
block.

35.  “Be gone!” Leading Zeros

A workaround for removing the leading zero from exported parameter based leaders.

”After placing the leader RMB on it and select Edit Unit Attributes and turn
off Leading Zeros.“

Thanks to Curt Fitzwater via the NG.

36.  Reorder An Assembly with this Workaround

From Kathy Johnson from the NG:

“Make a dummy assembly and place your working assembly in as the first and ground.
Now place your components into the dummy assembly.  Don't constrain.  Now Drag and 
Drop them into your working assembly at the point in the browser that you want (they 
won't end up at the bottom of the list).  Now edit your working assembly and
constrain.”

37.  Lock a Detail View In Place

You can anchor the detail callout in the parent view by high-lighting the callout and 
selecting "attach" from the RMB menu.  Select a point in the parent view and the callout 
will remain located relative to this point.

From Pat Rogers via the NG

38.  Select Multiple Parts in a Breakout View

First you RMB click on the view in the browser and select Show Contents,
then in the breakout view command you select the parts in the browser by
using CTRL or SHIFT to select more then one part.



The user interface needs to be corrected to show which parts are selected
for the breakout view, but it's possible.

From Patrick de Stobbeleir via the NG.

39.  New Ways to Split Parts

From Udaya Gunasena ( of Autodesk) via the NG:

You could use the Split command with an enclosed surface to get either the intersection 
volume or the subtracted volume.  I am posting this because this may not be well known.

Consider an assembly of two parts, A and B. If A is the first part it will be aligned with 
the assembly origin. Now start a new part and derive the assembly, ignoring A (in other 
words, derive only B). Derive A into the same part file, using the "Body as Work 
Surface" option. Next use the Split command, with the split part option, and select the 
surface as the Split Tool. With the default "Remove Direction" you should get the 
intersection volume (The other direction would give you the subtracted volume).

If A is not aligned with the assembly origin you would have to do derive the assembly 
into another part first, ignoring B. This would then be derived as the surface for split tool.

The subtraction method can be helpful with mold design. This technique can drastically 
reduce the number of extra files you need, compared to the usual derived assembly 
method. Basically you derive the part to be molded as a surface (and may be with a scale 
factor). Then create mold body and parting surface within the same part file.

40. Dynamic Section View Trick

by Teun Ham from the IV NG

Teun explains hot to make a dynamic section view in an assembly model.

1) Start new assembly
2) Place part/assembly
3) Unground part/assembly
4) Constrain part/assembly to origin, with 1 degree of freedom left
5) Select Section View --> Select workplane(s) of origin as section-planes
6) Drag part/assembly

More to come… check back soon…

Have a nifty trick or tip?  Email them to sean@sdotson.com and I’ll include them here 
with a credit to you.

mailto:sean@sdotson.com
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